Introduction

Lacewing is a set of networking extensions (and also a C/C++/JS library) designed to replace the outdated MOO objects and provide users with a simple way to network their games and applications. It has its own IRC-like relay protocol, and also a webserver. The man behind the magic is none other than Clickteam's own Jamie McLaughlin, with Mathias Kærlev as support mainly for the Python implementation (pylacewing). This documentation is designed for Lacewing Build #20, but the core concepts and most of the actions/conditions/expressions should remain relevant for later versions.

A brief history

Lacewing started out as OINC (OINC Internet/Network Controller), a replacement for MOO. As OINC was being developed however, Jamie experienced a hard drive crash and lost the source to OINC, forcing him to revert to an older version. At this point he renamed it Lacewing and created the liblacewing library that the client extension would use. There are now three parts to the Lacewing extension set; the Relay Client, the Relay Server, and the Webserver.

The Lacewing Relay Protocol

The Relay Client and Relay Server use the Lacewing Relay Protocol to communicate - it is an IRC-like communication protocol that allows for clients to connect to a server, have names, join channels, send messages to the channel to have them relayed to other peers in the channel, send messages to the server, and send messages to other peers in the channel. It also has support for each channel to have at most one channel master, which may optionally close the channel when they leave. Clients connected to a server may have the same name as other clients, so long as they are not in the same channel.

The main different between IRC and the LRP is that in IRC peer messages are per-server, and in LRP peer messages are per channel. Another difference is that there are three types of messages to be sent in the LRP; Text, Number, and Binary messages. messages sent to a channel are associated with a specific subchannel - channels have names, but subchannels are just numbers 0 through 255.

Core Concepts

To begin with, there are a few core concepts that you should understand to use Lacewing the intended way with ease. There are some key differences between MOO and Lacewing, such as when to set your name, that you need to understand. Make sure you understand channel/peer selection as well as the general concept of any given relay server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


Concepts

Starting off

To begin with, it is important to understand how to connect to a server, set your name, and join channels. The order is important: you must first connect to a server, then you must set your name. Only after you have set your name may you join a channel, request a channel list, or communicate with the server. Remember that connecting may not work and will give an error, the same applies to setting your name and joining channels.

Channel/Peer Selection

Just as MMF2 has object selection, Lacewing has peer and channel selection. You can't select yourself (just as you do not receive your own messages), so be careful when using the action to select the channel master - there is a condition to see if you are the channel master. Conditions that are fired (such as On Message, On Peer Join, etc, as well as loops) will automatically change your currently selected channel and, for peer related conditions, your currently selected peer. You can be connected to multiple channels at once, so it is important to monitor which channel messages are coming from by comparing to the selected channel expression. For this reason, it is important to first select the channel you will be dealing with right before you deal with it - the same applies to peers. You can also select peers by their ID, which is useful for games - you can store a peer's ID with their associated active object. If you have an ID or Name of a peer, you can get the other by selecting the peer and then using the expression you want.

Subchannels

Subchannels are integral values associated with each message you send, be it to the server, to a channel, or to a peer. The value can be any number in the range 0 to 255, inclusive, and is used per your standards to (often times) differentiate different kinds of information you will be sending. For example, you may use subchannel 0 for regular messages, subchannel 1 for IRC-styled /me messages, and subchannel 200 for commands. It is easiest to think of subchannels as literally being channels within channels, but having a number for a name instead of a string. There are 256 subchannels, so you shouldn't run out any time soon - especially since there are three kinds of messages.

Types of messages

In Lacewing there are three different kinds of messages that you can send to the server, to the channel, or to peers. The most common kind suitable to chat applications is the Text message, which is literally just plain text. The second type which is less commonly used is the Number message, which sends only an integer number in the same range that MMF2 supports. It cannot send floating-point values, such as 2.5. The third type of message, most commonly used for games, the the Binary message. You can send any combination of any kind of data you want, including strings, different types of numbers, files, or any data you want. This is often used to send things like X,Y coordinate pairs, or even X, Y, Angle, Velocity, Animation, Animation Frame, etc., which is why it is most suitable to games. If you want, you can also use it as a second half of a subchannel by using it to mimic a text message or number message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Servers

A server is the hub of any network related activity, as clients usually connect to a single server to perform networking tasks. Servers cannot connect to clients or force them to connect. Once connected, a client is under full control by the server to the extent of the protocol. In Lacewing, this means that a server can disconnect you, change your name, change channel names, change the channel master, and send messages to you or to channels. Servers can (rarely) disallow you from leaving channels, but they cannot disallow you from disconnecting. Servers can force you to leave channels, but cannot force you to join channels. Servers are also responsible for generating and sending the channel list upon your request.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Channels

A channel is an isolated 'room' where peers can send messages to other peers in the channel. Peer messages function on a per-channel basis. Channels have two properties: they can be forced to close when the channel master leaves, and they can be hidden from their point of creation. Hidden channels simply do not get listed with the channel list. You do not have to be connected to any channels to send messages to the server, however you can be connected to multiple channels at once.

Attempting to join a channel that does not exist results in the creation of that channel - this is the only time that the hidden and close on leave properties are modified. At this point you become the channel master, which is simply an automatically selected client to be treated as the channel controller. There can either be one channel master or no channel master, depending on whether the channel is set to close when the channel master leaves. Other than this, the channel master is just a normal peer. The only other time a channel is closed when a peer leaves is if that peer is the last peer in that channel, at which point the channel is destroyed.

Channels break one rule of selection: when the On Leave Channel condition is triggered, you are not in the channel, meaning you cannot determine the name of the channel you left - this is most likely a flaw. This is contrary to the On Peer Disconnect condition, where the peer still exists and you can access the peer's name and ID.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Peers

A peer is a client in a server. Peers can only interact with each other when they are in channels. Peers control everything that the server does not - for instance, in a multiplayer game, peers are the people playing the game and connecting to the same server to play together. In Lacewing's case, multiple games on the same server each occur within their own channel. Peers can also send messages to each other in private, but only via Peer A -> Server -> Peer B. Two or more peers may have the same name so long as they are not in the same channel and do not enter the same channel. Peers are usually identified by a unique ID number, so having two peers with the same name is no problem, because peers cannot interact outside of channels.

While the server is responsible for simulating games to keep cheating to a minimum, you (you are a client/peer) should only process your own movement and information, and only display other peers. It is important to remember to think of yourself as one peer interacting with others when programming with Lacewing. Peers should never take it upon themselves to fill in the role of the server (the channel master is an exception), and peers should not be held responsible for leaving channels themselves when being or forced to do other actions. For applications, it is up to you to decide how peers should interact with each other and the server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Clients

"Client" is just another name for "Peer". From the server's point of view, Peers are its Clients, and from each Client's point of view, Clients are Peers. You should consider yourself as a client rather than a peer, however.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Channel Masters

The Channel Master is the peer designated as, well, the master of a channel. The channel master is a peer/client like any other, and special treatment and/or special behavior should be decided upon by you, the programmer. If you want to take advantage of the channel master, design your events to handle both the case when you are the channel master and when you are not. Most events will be the same either way and do not need to check this. There can be either one channel master or no channel master per channel, and the server may change the channel master. Channels may close when the channel master leaves, or they may stay open in which case there will simply be no channel master. Be careful in your events: you cannot select yourself, so check to see if you are the channel master before selecting the channel master.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


Binary messages

Based on an article from Jamie.

Binary messages (previously called Stacks) are mixed-content messages. They can contain any combination of, and in an order, strings, numbers, files, some other form of data, etc. Because you design the structure of the messages yourself, you can, for example, use them to transfer the state of an object. For example, instead of using Text messages and separating different parts of the message with a token (such as a comma (,) or a pipe(|)), you can use binary messages to send them in a more condensed format.

Consider sending an X-Y coordinate pair:

104,178

As a string, this is 7 characters in length, plus a null termination character to mark the end of the string, meaning that you will be sending 8 whole bytes for every movement!

Using a stack message, however, you can condense the message size to 4 or even 2 bytes:

In the above example, two bytes (104 and 178) are sent, rather than 8. This is a huge bandwidth saver, as it is four times smaller than the Text message. This is important for fighting lag in games, as movement happens (usually) 60 times per second.

Using binary messages

A binary message must be created before it can be sent. To do this, you 'push' bytes onto the end of the message. The bytes can make up strings, numbers, or files. For numbers, there are different data types that use up a different number of bytes:

Building a binary message is easy, but reading it can be slightly harder. Indexes start at 0, meaning the first byte in a binary message is byte number 0, the second is byte number 1, the third is 2, etc. Consider a binary message comprised of the frame of an animation (eg 3), the size of a circle (eg 572), the score (eg 31333337), and the percent completion of the level (eg 100):

To read the stack upon receiving it, you would get the animation frame by getting the unsigned byte at 0, then a byte later at byte 1 you would read the size of the circle as an unsigned short. Remember though that a short takes up two bytes of space, so you would read the score as a signed integer two bytes later at byte 3. An integer is four bytes, so four bytes later at byte 7 you could read the unsigned (or signed) byte that represents the percent progress through the level. That makes all eight bytes accounted for. If you had sent this as a text message: "3,572,31333337,100" that would be 18+1 bytes, making for a whopping 19 byte message! That's over twice the 8 byte binary message!

You may now wonder why you can't choose to send a signed or unsigned type, but you have to choose when reading a number. For any given type, signed and unsigned take the same amount of of memory and, in fact, are represented exactly the same way! because the data is the same, the only reason to interpret it as signed (having a positive or negative sign) or unsigned (only being positive) is whether you want to be able to have it negative. As seen above, an unsigned byte has 256 different values, 0 to 255. A signed by also has 256 different values, -128 through 127. This is because the signed byte takes the unsigned byte's range 128 to 255 and uses it instead for -128 to -1. This means that unsigned 128 is the same as -128, 129 is the same as -127, and 255 is th same as -1.

There is an oddity in Lacewing: there exists and expression to read an unsigned integer. However, MMF2 can only process at most signed integers or double precision floats. This means that, while Lacewing may give MMF2 the data and expect it to interpret is in unsigned form, MMF2 interprets it in signed form instead. So, don't use this expression - it may be removed eventually. It is currently provided only for consistency and legacy.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Sending verus Blasting

Sending a message uses TCP, whereas Blasting a message uses UDP. Where TCP messages are guaranteed to make it to their destination alive and in the same order they were sent, UDP messages are not. Sometimes, a UDP message can be dropped, or it can arrive out of order. So why would anyone use such a protocol? Because it is much faster than TCP is. Generally you would Send a message with TCP if it was a chat message, whereas you would always want to Blast messages with UDP if they were position updates for an object. Object positions need to update quickly for the game to be playable. If a message is dropped or sent out of order, it will often be fixed in no time because you are sending so many so fast. If you decide to only send messages when said object moves, you should take precaution and make sure the last message is Sent and not Blasted to guarantee that it is in the correct spot when still.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Multiple channels

While connected to a server, it is possible to be in multiple channels at the same time. An example of the usage of this is an MDI chat, similar to our well known Gwerdy chat (which uses MOO unfortunately). It is important to both set and check which channel a message is going to/coming from, making multiple channels one of the more confusing concepts to utilize. Another problem is that when leaving a channel, you cannot know which channel has been left, as the channel is destroyed and thus not selected for the On Leave Channel condition.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Prefixing channel names

When dealing with games and software that will utilize multiple channels on a server, it is important to prefix channel names with a unique string on a per game/application basis. For instance, instead of "Lobby" for a channel name, which could be use by many different games and applications on a given server, it would be best to prefix the name: "[My Game/Software] Lobby". The prefix can also be used to filter channels from the channel list to show only channels related to your game or software. You can, of course, always remove the prefixes from start of the channel name so that the end user does not know anything about the magic in the background.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


Channel Listing

Channel lists are the list of non-hidden channels currently on the server, including each channel's name and peer count. Peers can request a channel list from the server at any time.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Examples

Lace Chat (original forum link)

This example will only work properly in MMF2 Developer. It shows how to make a Gwerdy-like MDI chat with Lacewing.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Bugs

Bugs

  • In the Relay Client, there is no way to know which channel has been left without keeping track of all channels manually
  • Both the Relay Client and Relay Server extensions have expressions to get the Unsigned form of a 32-bit integer from a binary message, which MMF2 promptly truncates to a Signed 32-bit integer
  • In the Relay Server extension, there is no way to loop the clients in a channel with a loop name despite there being conditions for such a thing
  • In the Relay Server extension, the On <...> message to peer sent/blasted, it is ambiguous as to whether the to client or from client is selected, and there does not appear to be a way to determine the other client
  • Lacewing Relay Server->Conditions->Channel->Client->On channel clients loop/finished (obvious copy paste error)
  • Lacewing Relay Server->Expressions->Client->Connection time (removed expression, menu item left in)
  • Lacewing Relay Server->Expressions->Client->Get client protocol implementation (removed expression, menu item left in)
  • In the Webserver object, there is no way to set local connection data, despite there being expressions to retrieve such data
  • Lacewing Webserver->Expressions->Guess MIME type for filename (parameter list is incorrect)

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Extension Set

The Lacewing set of extensions allows you to easily create advanced networked applications and games. The three extensions currently in the set include the Relay Client, the Relay Server, and the Webserver.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Lacewing Relay Client

The Lacewing Relay Client is the main object of the Lacewing extension set, as it allows you to connect to a server, join channels, and interact with peers. Beyond that, is is up to you, the programmer, to design the way that peers should interact with each other and the server, be it for a game or for an application such as a chat program. Think of the Relay Client as representing your application, interacting with other instances of the same application. You shouldn't design programs with different code for different peers (eg: don't design separate sender and receiver programs) - instead, design your events such that you treat yourself as a peer equal to all other peers.

The Lacewing Relay Client is the only part of Lacewing that has been ported to Flash (AS3). The liblacewing library still has no public AS3 port, so this makes the Lacewing Relay Client extension a black sheep out of the bundle.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Connect

This action is used to start the connection process and attempt to connect to a server. This action takes one string parameter, which is the server (and optionally the port) to connect to. Here are some examples:

"ledev.org" - only the server host name is specified, port 6121 will be used by default

"ledev.org:6124" - both the server host name and port are specified, connection will occur on port 6124

"127.0.0.1" - an IP address is specified, default port 6121 will be used.

"localhost" - same as "127.0.0.1"

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Disconnect

This action terminates an active connection. It does not take any parameters. You literally disconnect from the server, leaving any channels you were in, meaning that if you were the channel master and you chose to close the channel when you leave, the channels will close. Channels will also close if you were the last peer in that channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Set Name

This action is used to initially set your name or to change it after it has been set. It takes one string parameter, which is the new name you want to set for yourself. The server may deny the name or change it, so it is important to use the Self Name expression rather than expecting to have the name you requested. Names may have any characters (including spaces and new lines) and my be any length other than zero. Two clients on a server may have the exact same name at the same time as long as they are not in and do not enter the same channels. Names maintain their case but are case insensitive. Thus, three users "Jamie", "jamie", and "jamie" can be on the same server but not the same channels.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Request list

This action requests the list of public channels from the server. See Channel Listing for more information.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Loop listed channels

This action loops through the last received channel list, but does not have a loop name for efficiency (and legacy). See Channel Listing for more information.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Loop listed channels (with loop name)

This action is the same as Loop listed channels, but uses a loop name and fires the related events. It takes one string parameter, which is the name of the loop. The name can be anything at all, including a blank string "", and may contain anything at all, including new lines. See Channel Listing for more information.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


By name

This action allows you to select a channel you are currently in by specifying its name. It takes one string parameter, which is the name of the channel you want to select.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


Loop

This action starts a nameless loop of all the channels you are currently in.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Loop (with loop name)

This action is the same as Loop Channels, but allows you to specify a name for the loop. It takes one string parameter, which is the name of the loop. The name can be anything at all, including a blank string "", and may contain anything at all, including new lines.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


Join

This action allows you to join channels, which are the only places where you can communicate with other peers. It takes, in order, a string parameter that is the name of the channel (which can be anything), then a number which, when 0 means public channel, and when 1 means private channel, and another number which, when 0 means to keep the channel open if the channel master leaves, and when 1 means the close the channel if the channel master leaves. The last two parameters only apply if the channel does not yet exist, in which case it is created and you automatically become the channel master. The server may change which peer in a channel is the channel master.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Leave

This action is used to leave a channel. It takes not parameters; the channel it will request to leave is the currently selected channel. Normal servers will not deny channel leaving, only customized servers may deny this. It is always possible to leave a channel you are not allowed to leave by disconnecting - there is no way for a server to prevent you from disconnecting.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


Select by name

This action, similar to selecting a channel by name, selects a peer in the current channel by their name. it takes one parameter, which is the name of the peer you want to select.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Select by ID

This action, similar to selecting a peer by name, selects a peer in the current channel by their ID. It takes one parameter, which is the ID of the peer you want to select.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Select the channel master

This action selects the channel master of the current channel. Some channels may not have a channel master, in which case the channel master cannot be selected. Also, it is possible that you are the channel master, and because you cannot select yourself, this also means you cannot select the channel master. This action takes no parameters.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Loop

This action loops through all the peers in the currently selected channel. This action takes no parameters.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Loop (with loop name)

This action is the same as loop peers in channel, but it allows you to specify a loop name. It takes one string parameter, which is the name of the loop. The name can be anything at all, including a blank string "", and may contain anything at all, including new lines.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


To server

This action allows you to send text to the server. It takes two parameters, the first being the subchannel to send the message on, and the second being the text itself to send. Only customized servers will have any reaction to this, as by default a normal server just ignores received messages.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


To channel

This action allows you to send text to the currently selected channel. It takes two parameters, the first being the subchannel to send the message on, and the second being the text itself to send. The server, if it chooses, will then relay the message to the other peers in the channel. You will not receive your own message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


To peer

This action allows you to send text to the currently selected peer in the currently selected channel. It takes two parameters, the first being the subchannel to send the message on, and the second being the text itself to send. The server, if it chooses, will send the message to the peer. The server may change the To and From peers for the message if it is a custom server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


To server

This action allows you to send a number to the server. It takes two parameters, the first being the subchannel to send the message on, and the second being the number itself to send. Only customized servers will have any reaction to this, as by default a normal server just ignores received messages.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


To channel

This action allows you to send a number to the currently selected channel. It takes two parameters, the first being the subchannel to send the message on, and the second being the number itself to send. The server, if it chooses, will then relay the message to the other peers in the channel. You will not receive your own message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


To peer

This action allows you to send a number to the currently selected peer in the currently selected channel. It takes two parameters, the first being the subchannel to send the message on, and the second being the number itself to send. The server, if it chooses, will send the message to the peer. The server may change the To and From peers for the message if it is a custom server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


To server

This action allows you to send a binary message to the server. It takes one parameter: the subchannel to send the message on. If you have Automatically clear binary checked, then the binary will be cleared after sending the message. Otherwise, the binary will stay for the next message. Only customized servers will have any reaction to this, as by default a normal server just ignores received messages.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


To channel

This action allows you to send a binary message to the currently selected channel. It takes one parameter: the subchannel to send the message on. If you have Automatically clear binary checked, then the binary will be cleared after sending the message. Otherwise, the binary will stay for the next message. The server, if it chooses, will then relay the message to the other peers in the channel. You will not receive your own message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


To peer

This action allows you to send a binary message to the currently selected peer in the currently selected channel. It takes one parameter: the subchannel to send the message on. If you have Automatically clear binary checked, then the binary will be cleared after sending the message. Otherwise, the binary will stay for the next message. The server, if it chooses, will send the message to the peer. The server may change the To and From peers for the message if it is a custom server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


To server

This action allows you to blast text to the server. It takes two parameters, the first being the subchannel to blast the message on, and the second being the text itself to blast. Only customized servers will have any reaction to this, as by default a normal server just ignores received messages.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


To channel

This action allows you to blast text to the currently selected channel. It takes two parameters, the first being the subchannel to blast the message on, and the second being the text itself to blast. The server, if it chooses, will then relay the message to the other peers in the channel. You will not receive your own message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


To peer

This action allows you to blast text to the currently selected peer in the currently selected channel. It takes two parameters, the first being the subchannel to blast the message on, and the second being the text itself to blast. The server, if it chooses, will blast the message to the peer. The server may change the To and From peers for the message if it is a custom server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


To server

This action allows you to blast a number to the server. It takes two parameters, the first being the subchannel to blast the message on, and the second being the number itself to blast. Only customized servers will have any reaction to this, as by default a normal server just ignores received messages.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


To channel

This action allows you to blast a number to the currently selected channel. It takes two parameters, the first being the subchannel to blast the message on, and the second being the number itself to blast. The server, if it chooses, will then relay the message to the other peers in the channel. You will not receive your own message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


To peer

This action allows you to blast a number to the currently selected peer in the currently selected channel. It takes two parameters, the first being the subchannel to blast the message on, and the second being the number itself to blast. The server, if it chooses, will blast the message to the peer. The server may change the To and From peers for the message if it is a custom server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


To server

This action allows you to blast a binary message to the server. It takes one parameter: the subchannel to blast the message on. If you have Automatically clear binary checked, then the binary will be cleared after blasting the message. Otherwise, the binary will stay for the next message. Only customized servers will have any reaction to this, as by default a normal server just ignores received messages.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


To channel

This action allows you to blast a binary message to the currently selected channel. It takes one parameter: the subchannel to blast the message on. If you have Automatically clear binary checked, then the binary will be cleared after blasting the message. Otherwise, the binary will stay for the next message. The server, if it chooses, will then relay the message to the other peers in the channel. You will not receive your own message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


To peer

This action allows you to blast a binary message to the currently selected peer in the currently selected channel. It takes one parameter: the subchannel to blast the message on. If you have Automatically clear binary checked, then the binary will be cleared after blasting the message. Otherwise, the binary will stay for the next message. The server, if it chooses, will blast the message to the peer. The server may change the To and From peers for the message if it is a custom server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


ASCII character

This action adds one byte to the end of the current binary message. It takes one sting parameter, which is the character you want to add. You should only put one character in the string, eg "c". If you want to add multiple characters at once, use one of the Add string actions instead.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Integer value

This action adds one byte to the end of the current binary message. It takes one parameter: the integral value of the byte you want to add. It does not matter if it is signed or unsigned, as the binary representations are the same. Remember that the range of a byte is -128 to 127 or 0 to 255, depending on how it is interpreted by the receiver.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Add short

This action adds two bytes to the end of the current binary message. It takes one parameter: the integral value of the short you want to add. It does not matter if it is signed or unsigned, as the binary representations are the same. Remember that the range of a short is -32768 to 32767 or 0 to 65535, depending on how it is interpreted by the receiver.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Add integer

This action adds four bytes to the end of the current binary message. It takes one parameter: the integral value of the integer you want to add. It does not matter if it is signed or unsigned, as the binary representations are the same - additionally, MMF2 can only handle signed integers at most. Remember that the range of an integer is -2147483648 to 2147483647.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Add float

This action adds four bytes to the end of the current binary message. It takes one parameter: the floating point value of the float you want to add. MMF2 can handle double precision floats, which are eight bytes, but can only give extensions four bytes at most, which is why Lacewing only lets you send floats and not doubles. Remember that the range of a float is 3.4e-38 to 3.4e38.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Without null terminator

This action allows you to simply add a plain string to the end of the current binary data. The number of bytes added is literally the length of the string in characters. It takes one parameter: the string to add.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


With null terminator

This action allows you to add a null-terminated string to the end of the current binary data. The number of bytes added is the length of the string in characters plus one for the null character (byte value 0). It takes one parameter: the string to add.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


Add binary

This action is for advanced usage; it takes two parameters: the location of binary in memory, and how much of it you want to add. The number of bytes added is literally the second parameter. This is useful in conjunction with objects such as the Binary object and/or the Memory object.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Add file

This action allows you to add an entire file to the end of the current binary data. It takes one parameter, which is the file to add. You can choose to use an expression to evaluate the file path. Do not send large files, the most a binary message can hold is 65535 bytes. If you intend to send large files, you should break the file up into smaller chunks and send them individually.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Compress (ZLIB)

This action compresses the binary using ZLIB compression routines. You should find a balance between faster send/blast time with smaller binary messages and faster message generation/interpreting time when not compressing/decompressing the binary message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Clear

This action simply clears the binary to send and sets its size to 0. If you have Automatically clear binary checked, then this action will occur whenever you send/blast a binary message. Otherwise, it is up to you to decide when to clear a binary message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Resize

This action will resize the binary to send to whatever number of bytes you specify via the only parameter. This is useful in conjunction with the Binary to send address expression, as you can load binary into the existing memory though another object (such as Binary Quickload).

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Save to a file

This action allows you to save a portion of the received binary to a file, overwriting the file if it already exists. It takes three parameters, the first being the position in the received binary to be the start of the file, the second being how many bytes after that you want to save to the file, and the third being a string expression for the path to the file to save to.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Append to a file

This action allows you to save a portion of the received binary to the end of a file, creating the file if it does not exist. It takes three parameters, the first being the position in the received binary to be the start of the file, the second being how many bytes after that you want to save to the file, and the third being a string expression for the path to the file to save to.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Uncompress (ZLIB)

This action simply decompresses the received binary using ZLIB compression routines.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Move cursor

This action moves the cursor in the received binary for cursor related expressions. It takes one parameter: the new position for the cursor.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


On error

I This condition is triggered when an error occurs. You can use the Error string expression to get the error in string format. There are many things that can cause an error, but there has been no official public list.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


On connect

I This condition is triggered as soon as connection is successful. You can use the Get welcome message expression to get the server's MOTD.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


On connection denied

I This condition is triggered as soon as connection to a server has been denied. You can use the Deny reason expression to get the reason.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Is connected

N This condition is used to test if you are connected to a server or not.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


On disconnect

I This condition is triggered as soon as you have disconnected from a server, be it by your own events or the server terminating its connection with you.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


On list received

I This condition is triggered as soon as the channel list has been fully received. You can then start looping through with either the nameless or named loop actions.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


On loop

I This condition is triggered for each channel in the channel list. You can use the Get name and Get peer count expressions to get information about the channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


On loop finished

I This condition is triggered after the last channel in the channel list have been listed (via triggering the On loop condition). This is only for convenience, as it would have the same effect as putting events after the Loop listed channels action.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


[With loop name] On loop

I This condition is triggered for each channel in the channel list. You can use the Get name and Get peer count expressions to get information about the channel. This condition takes one string parameter, which is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


[With loop name] On loop finished

I This condition is triggered after the last channel in the channel list have been listed (via triggering the On loop condition). This is only for convenience, as it would have the same effect as putting events after the Loop listed channels action. This condition takes one string parameter, which is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


On join

I This condition is triggered as soon as you join a channel. You can start a peer loop on the channel to see what peers are already there.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


On join denied

I This condition is triggered as soon as joining a channel has been denied. You can use the Deny reason expression to get the reason. However, much like with the On leave condition, you cannot get the name of the channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


On leave

I This condition is triggered as soon as you leave a channel, be it by your own events or from the server kicking you from that channel. You cannot get the name of the channel you left, unfortunately, making this condition the arch nemesis of people in multiple channels at once. The only way to find out which channel you have left is to loop through all the channels you are in and see which is missing.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


On leave deined

I This condition is triggered as soon as connection to a server has been denied. You can use the Deny reason expression to get the reason. Note that the default server behavior will never deny you leaving a channel, only customized servers may do this - thus, the only time you should worry about this condition is if you are designing the server with this behavior or if you know the server will do this.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


On joined channel loop

I This condition is triggered for each channel you are in when you use the Loop channels action. It changes the selected channel, so you can use the Channel name expression to get the name of the channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


On joined channel loop finished

I This condition is triggered when the joined channel loop is finished, after all channels have been iterated.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


[With loop name] On joined channel loop

I This condition is triggered for each channel you are in when you use the Loop channels action that uses a loop name. It changes the selected channel, so you can use the Channel name expression to get the name of the channel. It takes one string parameter, which is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


[With loop name] On joined channel loop finished

I This condition is triggered when the joined channel loop is finished, after all channels have been iterated. It takes one string parameter, which is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


On peer connect

I This condition is triggered when a peer joins any channel you are in. It automatically selects the channel and peer for you so you can get the channel name and peer name/ID.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


On peer disconnect

I This condition is triggered when a peer leaves any channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


On peer changed name

I This condition is triggered when a peer changes their name while they are in any channel that you are also in. The channel and peer are selected for you so you can get the channel name and the peer ID/old name/new name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


On loop

I This condition is triggered for each peer in a channel when you use peer loops. The channel and peer are selected for you so you can get the channel name and peer name/ID.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


On loop finished

I This condition is triggered when all the peers in a channel have been iterated. The channel is selected for you so you can get the channel name. This is useful for adding yourself to the end of a user list.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


[With loop name] On loop

I This condition is triggered for each peer in a channel when you use peer loops. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


[With loop name] On loop finished

I This condition is triggered when all the peers in a channel have been iterated. The channel is selected for you so you can get the channel name. This is useful for adding yourself to the end of a user list. It takes one parameter, which is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Selected peer is the channel master

N This condition is true if the currently selected peer in the currently selected channel is the channel master.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


You are the channel master

N This condition is true if you are the channel master of the currently selected channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


On name set

I This condition is triggered when your name is first set after previously not having a name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


On name deined

I This condition is triggered when your newly requested name is denied, either when you are first setting your name or when you are changing it. You can use the Deny reason expression to get the reason.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


On name changed

I This condition is triggered when you have successfully changed your name, but not when you previously did not have a name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Client has a name

N This condition is true when you have a name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


To me

I This condition is triggered when the server sends a text message to you. It can happen when you aren't even in any channels. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


To channel

I This condition is triggered when the server sends a text message to a channel that you are currently in. The channel is selected for you so that you can get the channel name. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


To me

I This condition is triggered when the server sends a number message to you. It can happen when you aren't even in any channels. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


To channel

I This condition is triggered when the server sends a number message to a channel that you are currently in. The channel is selected for you so that you can get the channel name. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


To me

I This condition is triggered when the server sends a binary message to you. It can happen when you aren't even in any channels. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


To channel

I This condition is triggered when the server sends a binary message to a channel that you are currently in. The channel is selected for you so that you can get the channel name. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


To me

I This condition is triggered when the server sends any message to you. It can happen when you aren't even in any channels. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


To channel

I This condition is triggered when the server sends any message to a channel that you are currently in. The channel is selected for you so that you can get the channel name. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


On text message from channel

I This condition is triggered when a peer sends a text message to a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


On number message from channel

I This condition is triggered when a peer sends a number message to a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


On binary message from channel

I This condition is triggered when a peer sends a binary message to a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


On any message from channel

I This condition is triggered when a peer sends any message to a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


On text message from peer

I This condition is triggered when a peer sends a text message to you in a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


On number message from peer

I This condition is triggered when a peer sends a number message to you in a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


On binary message from peer

I This condition is triggered when a peer sends a binary message to you in a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


On any message from peer

I This condition is triggered when a peer sends any message to you in a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


To me

I This condition is triggered when the server blasts a text message to you. It can happen when you aren't even in any channels. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


To channel

I This condition is triggered when the server blasts a text message to a channel that you are currently in. The channel is selected for you so that you can get the channel name. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


To me

I This condition is triggered when the server blasts a number message to you. It can happen when you aren't even in any channels. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


To channel

I This condition is triggered when the server blasts a number message to a channel that you are currently in. The channel is selected for you so that you can get the channel name. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


To me

I This condition is triggered when the server blasts a binary message to you. It can happen when you aren't even in any channels. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


To channel

I This condition is triggered when the server blasts a binary message to a channel that you are currently in. The channel is selected for you so that you can get the channel name. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


To me

I This condition is triggered when the server blasts any message to you. It can happen when you aren't even in any channels. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


To channel

I This condition is triggered when the server blasts any message to a channel that you are currently in. The channel is selected for you so that you can get the channel name. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


On text message from channel

I This condition is triggered when a peer blasts a text message to a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


On number message from channel

I This condition is triggered when a peer blasts a number message to a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


On binary message from channel

I This condition is triggered when a peer blasts a binary message to a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


On any message from channel

I This condition is triggered when a peer blasts any message to a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


On text message from peer

I This condition is triggered when a peer blasts a text message to you in a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


On number message from peer

I This condition is triggered when a peer blasts a number message to you in a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


On binary message from peer

I This condition is triggered when a peer blasts a binary message to you in a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


On any message from peer

I This condition is triggered when a peer blasts any message to you in a channel you are currently in. The channel and peer are selected for you so you can get the channel name and peer name/ID. It takes one parameter, which is the subchannel to filter this event for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Error string (for on error)

S This expression returns the error message for the On error condition.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Lacewing version string

S This expression returns the version string of Lacewing. For example, this help file was created for the version of Lacewing "liblacewing #20 (Windows/x86)".

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Binary to send size

N This expression returns the size in bytes of the binary to send.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Binary to send address

N This expression returns the memory address of the binary to send. This is commonly used on conjunction with objects such as the Memory object and Binary Quickload.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Deny reason (for on [..] denied)

S This expression returns the reason for denying an action when one of the On [..] denied conditions triggers.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Get welcome message (for on connect)

S This expression returns the welcome message (similar to MOTD) for the On connect condition.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Host IP address

S This expression returns the IP address of the server you are currently connected to. This will always be in the format "###.###.###.###".

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Host port

N This expression returns the port that you are connected through to the server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Get name

S This expression returns the name of the current channel in the channel list loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Get peer count

N This expression returns the number of peers in the channel being listed in the channel list loop. This number includes yourself if you are in that channel, thus there should never be a channel with 0 peers.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Get text

S This expression returns the received text message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


Get number

N This expression returns the received number message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Get binary size

N This expression returns the size in bytes of the received binary message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Get binary memory address

N This expression returns the memory address of the received binary. This is often used in conjunction with the Memory object.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


ASCII character

S This expression returns a string containing the single character represented by the indicated byte. It takes one parameter, which is the location of the byte in the binary message, with a 0-based index.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Unsigned

N This expression returns the unsigned representation of the single byte at the specified location in the binary message. It takes one parameter, which is the location of the byte in the binary message, with a 0-based index. The value returned will be in the range 0 to 255.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Signed

N This expression returns the signed representation of the single byte at the specified location in the binary message. It takes one parameter, which is the location of the byte in the binary message, with a 0-based index. The value returned will be in the range -128 to 127.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Unsigned

N This expression returns the unsigned representation of the two-byte short at the specified location in the binary message. It takes one parameter, which is the location of the short in the binary message, with a 0-based index. The value returned will be in the range 0 to 65535.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


Signed

N This expression returns the signed representation of the two-byte short at the specified location in the binary message. It takes one parameter, which is the location of the short in the binary message, with a 0-based index. The value returned will be in the range -32768 to 32767.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Unsigned

N This expression returns the unsigned representation of the four-byte integer at the specified location in the binary message. It takes one parameter, which is the location of the integer in the binary message, with a 0-based index. The value returned would be in the range 0 to 4294967295, but MMF2 will truncate this value to be within the range -2147483648 to 2147483647, making this expression the same as getting the Signed integer.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Signed

N This expression returns the signed representation of the four-byte integer at the specified location in the binary message. It takes one parameter, which is the location of the integer in the binary message, with a 0-based index. The value returned will be in the range -2147483648 to 2147483647.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Float

N This expression returns the floating-point representation of the four-byte float at the specified location in the binary message. It takes one parameter, which is the location of the float in the binary message, with a 0-based index. The value returned will be in the range -3.4e38 to 3.4e38.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


With size

S This expression returns the string at the specified location in the binary message. It takes two parameters, the first being the location of the string in the binary message, with a 0-based index, and the second being the size in bytes/characters of the string to read.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Null terminated

S This expression returns the string at the specified location in the binary message. It takes one parameter, which is the location of the string in the binary message, with a 0-based index. The string will be read until a null terminator character is found in the binary message (byte value 0).

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


ASCII character

S This expression returns a string containing the single character represented by the byte at the cursor.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Unsigned

N This expression returns the unsigned representation of the single byte at the cursor. The value returned will be in the range 0 to 255.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


Signed

N This expression returns the signed representation of the single byte at the cursor. The value returned will be in the range -128 to 127.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Unsigned

N This expression returns the unsigned representation of the two-byte short at the cursor. The value returned will be in the range 0 to 65535.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


Signed

N This expression returns the signed representation of the two-byte short at the cursor. The value returned will be in the range -32768 to 32767.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Unsigned

N This expression returns the unsigned representation of the four-byte integer at the cursor. The value returned would be in the range 0 to 4294967295, but MMF2 will truncate this value to be within the range -2147483648 to 2147483647, making this expression the same as getting the Signed integer.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Signed

N This expression returns the signed representation of the four-byte integer at the cursor. The value returned will be in the range -2147483648 to 2147483647.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Float

N This expression returns the floating-point representation of the four-byte float at the cursor. The value returned will be in the range -3.4e38 to 3.4e38.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


With size

S This expression returns the string at the cursor. It takes one parameter, which is the size in bytes/characters of the string to read.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Null terminated

S This expression returns the string at the cursor. The string will be read until a null terminator character is found in the binary message (byte value 0).

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Get subchannel

N This expression returns the subchannel that the message was received on.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Name

S This expression returns your name, and should always be used rather than keeping a separate record.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


ID

N This expression returns your unique ID on the server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Number of channels

N This expression returns the number of channels you are currently in.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


Previous name (for on name changed)

S This expression returns your previous name for the On name changed condition.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Name

S This expression returns the name of the currently selected channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Number of peers

N This expression returns the number peers (excluding yourself) that are in the currently selected channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Name

S This expression returns the name of the currently selected peer in the currently selected channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


ID

N This expression returns the unique ID of the currently selected peer in the currently selected channel on the server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Previous name (for on peer name changed)

S This expression returns the previous name of a peer for the On peer changed name condition.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Version

This property shows you the version of the liblacewing library that this Lacewing Relay Client extension was compiled with. Refer to the build number when asked which version of Lacewing you use. For example, this help file was made for Lacewing Build #20. This can be retrieved at runtime with the Lacewing version string expression.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Automatically clear binary

This property allows you to control whether the binary to send is automatically cleared after sending/blasting a binary message. It cannot be changed at runtime.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


Global

This property is used on conjunction with the Global identifier property. It determines whether Lacewing will stay active across frames and even sub applications. This property cannot be changed at runtime. Note: if this is checked and you have a connection and go to a frame where there is not a matching global Lacewing Relay Client, the connection will remain active. Returning to a frame with a matching LRC will allow you to once again control the connection.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Global identifier

This property is used in conjunction with the Global property. This is a unique global identifier to separate/conjoin separate global Lacewing Relay Client extensions from/with each other within the same application. it can be anything at all, even a sentence with spaces, or it can be blank. As long as it is the same as another LRC extension somewhere else in the application, they will be considered the same object.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Lacewing Relay Server

The Lacewing Relay Server is an object which allows you to host and somewhat customize the behavior of a Lacewing Relay Server. Relay Clients connect to Relay Servers, and with this object you may control server-side behavior. This object should be used only if public servers do not provide the functionality needed (such as being for specific games, having custom behavior (like simulating games to prevent cheating), or for responding to moderation commands for chat programs). The Relay Server sees peers as its Clients.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Host

This action attempts to begin hosting the Relay Server. It takes one parameter, which is the port to host on. This may trigger an error, for instance, when there is already a server (of any kind) hosting on the specified port, be it TCP, UDP, or both.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Stop hosting

This action stops hosting if the server is hosting at all. It generates an error if the server is not hosting.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Host

This action attempts to begin hosting the Relay Server. It takes one parameter, which is the Flash Policy XML file to host - it will always host on port 843, whether you want it to or not. This may trigger an error, for instance, when there is already a server (of any kind) hosting on port 843, or if the file can't be used.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Stop hosting

This stops hosting a policy file, generating an error if no policy file was being hosted in the first place.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Set welcome message

This action allows you to set the welcome message that clients receive when they connect to the server. The only parameter is the welcome message string. The string can be blank, have new lines, etc.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


On message to channel

This action allows the "On message to channel" condition to be triggered so that you may have more fine grained control over the behavior of the server. Normally, for efficiency purposes, this condition is disabled from being triggered. This action takes no parameters.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


On message to peer

This action allows the "On message to peer" condition to be triggered so that you may have more fine grained control over the behavior of the server. Normally, for efficiency purposes, this condition is disabled from being triggered. This action takes no parameters.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Deny (for on [..] request)

This action allows you to give the generic 'request denied'. It does not allow you to set the deny reason message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Change name (for name set/change request)

This action allows you to change the name of a client from their requested name. This allows you to give them an entirely different name from what they requested, though it is not recommended to do so. Its only parameter is the new name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Change channel name (for channel join request)

This action allows you to change the name of a channel from the requested name as it is being created. This allows you to give the channel an entirely different name from what was requested, though it is not recommended to do so. Its only parameter is the new name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


Drop message (for on message to channel/peer)

This action is the 'silent' version of the Deny action - it simply refuses to send any message at all, but leaves no trace (eg there is no error message or notice sent to the client that send the message or the client(s) that would have received the message).

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Close channel

Closes the currently selected channel. All peers within are forced to leave the channel. Any local channel data stored with the channel is lost.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Select the channel master

Sets the currently selected peer as the channel master of the currently selected channel. This can be used to create behavior where if the channel master leaves a new one is picked. There is no way to make a channel not have a channel master if it has one, however, without completely disconnecting the channel master from the server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Loop clients

Starts a client loop of all the clients in the currently selected channel. There is no version of this action that uses a loop name, despite there being conditions for such an action.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Select by name

Selects a channel by the given name parameter.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


Loop all channels

Starts a channel loop of all channels on the server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Loop all channels (with loop name)

Starts a channel loop of all channels on the server with the given loop name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


Set local channel data

This action allows you to set server-side information about a channel. For the current channel, it associates a string value with a key. The first parameter is the key to use, and the second is the new string value to store with that key. This is very useful for storing information such as game session information, channel state information, etc., but all the data is lost when the channel closes.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Disconnect

This action forcefully disconnects a client from the server, causing them to leave all channels they are in. Any local client data stored with the client is lost.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Loop client channels

This action starts a loop of all the channels the client is currently in.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Loop client channels (with loop name)

This action starts a loop of all the channels the client is currently in using the given loop name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Select by name

Selects a client on the server by the given name parameter. Because there can be more than one client with the same name on a server, this action should be avoided when possible.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Select by ID

Selects a client by the given ID parameter. All clients are guaranteed to have a unique ID.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Select sender (for "on message to peer")

This action allows you to modify the 'from' peer of a peer message (not a channel message) by setting the currently selected peer as the peer who sent the message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Select receiver (for "on message to peer")

This action allows you to modify the 'to' peer of a peer message (not a channel message) by setting the currently selected peer as the peer to receive the message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Loop all clients

This action starts a loop of all the clients on the server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Loop all clients (with loop name)

This action starts a loop of all the clients on the server with the given loop name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Set local client data

This action allows you to set server-side information about a client. For the current client, it associates a string value with a key. The first parameter is the key to use, and the second is the new string value to store with that key. This is very useful for storing information such as game session information, client state information, etc., but all the data is lost when the client disconnects.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


To client

This action sends text to the currently selected client. It takes two parameters: the subchannel to send on, and the text to send.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


To channel

This action sends text to the currently selected channel. It takes two parameters: the subchannel to send on, and the text to send.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


To client

This action sends a number to the currently selected client. It takes two parameters: the subchannel to send on, and the number to send.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


To channel

This action sends a number to the currently selected channel. It takes two parameters: the subchannel to send on, and the number to send.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


Stack

Fun fact: this submenu should actually be named "Binary". "Stack" is the previous name used for this feature.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


To client

This action sends a binary message to the currently selected client. It takes one parameter: the subchannel to send on.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


To channel

This action sends a binary message to the currently selected channel. It takes one parameter: the subchannel to send on.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


To client

This action blasts text to the currently selected client. It takes two parameters: the subchannel to blast on, and the text to blast.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


To channel

This action blasts text to the currently selected channel. It takes two parameters: the subchannel to blast on, and the text to blast.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


To client

This action blasts a number to the currently selected client. It takes two parameters: the subchannel to blast on, and the number to blast.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


To channel

This action blasts a number to the currently selected channel. It takes two parameters: the subchannel to blast on, and the number to blast.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


To client

This action blasts a binary message to the currently selected client. It takes one parameter: the subchannel to blast on.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


To channel

This action blasts a binary message to the currently selected channel. It takes one parameter: the subchannel to blast on.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Integer value

This action adds one byte to the end of the current binary message. It takes one parameter: the integral value of the byte you want to add. It does not matter if it is signed or unsigned, as the binary representations are the same. Remember that the range of a byte is -128 to 127 or 0 to 255, depending on how it is interpreted by the receiver.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Add short

This action adds two bytes to the end of the current binary message. It takes one parameter: the integral value of the short you want to add. It does not matter if it is signed or unsigned, as the binary representations are the same. Remember that the range of a short is -32768 to 32767 or 0 to 65535, depending on how it is interpreted by the receiver.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Add integer

This action adds four bytes to the end of the current binary message. It takes one parameter: the integral value of the integer you want to add. It does not matter if it is signed or unsigned, as the binary representations are the same - additionally, MMF2 can only handle signed integers at most. Remember that the range of an integer is -2147483648 to 2147483647.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Without null terminator

This action allows you to simply add a plain string to the end of the current binary data. The number of bytes added is literally the length of the string in characters. It takes one parameter: the string to add.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


With null terminator

This action allows you to add a null-terminated string to the end of the current binary data. The number of bytes added is the length of the string in characters plus one for the null character (byte value 0). It takes one parameter: the string to add.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Add binary

This action is for advanced usage; it takes two parameters: the location of binary in memory, and how much of it you want to add. The number of bytes added is literally the second parameter. This is useful in conjunction with objects such as the Binary object and/or the Memory object.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Add file

This action allows you to add an entire file to the end of the current binary data. It takes one parameter, which is the file to add. You can choose to use an expression to evaluate the file path. Do not send large files, the most a binary message can hold is 65535 bytes. If you intend to send large files, you should break the file up into smaller chunks and send them individually.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Resize

This action will resize the binary to send to whatever number of bytes you specify via the only parameter. This is useful in conjunction with the Binary to send address expression, as you can load binary into the existing memory though another object (such as Binary Quickload).

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Compress (ZLIB)

This action compresses the binary using ZLIB compression routines. You should find a balance between faster send/blast time with smaller binary messages and faster message generation/interpreting time when not compressing/decompressing the binary message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Clear

This action simply clears the binary to send and sets its size to 0. If you have Automatically clear binary checked, then this action will occur whenever you send/blast a binary message. Otherwise, it is up to you to decide when to clear a binary message.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Save to a file

This action allows you to save a portion of the received binary to a file, overwriting the file if it already exists. It takes three parameters, the first being the position in the received binary to be the start of the file, the second being how many bytes after that you want to save to the file, and the third being a string expression for the path to the file to save to.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


Append to a file

This action allows you to save a portion of the received binary to the end of a file, creating the file if it does not exist. It takes three parameters, the first being the position in the received binary to be the start of the file, the second being how many bytes after that you want to save to the file, and the third being a string expression for the path to the file to save to.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


Move cursor

This action moves the cursor in the received binary for cursor related expressions. It takes one parameter: the new position for the cursor.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


On Error

This condition is triggered whenever an error occurs.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


Lacewing server is hosting

This condition is true if the server is hosting at all.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Flash Player policy server is hosting

This condition is true if the flash policy server is hosting at all.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


On connect request

This condition is triggered when a client requests connection to the server. The client will be selected for you.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


On disconnect

This condition is triggered when a client disconnects from the server. The client will be selected for you.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


On join request

This condition is triggered when a client requests to join a channel. The client will be selected for you, but the channel will not as it has yet to be created.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


On leave request

This condition is triggered when a client requests to leave a channel they are in. Both the client and channel will be selected for you. It would be evil to deny them from leaving the channel, though it is an action you can do during this event.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


On all channels loop

This condition is triggered for each channel in a channel loop of all channels on the server. The channel will be selected for you.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


On all channels loop finished

This condition will be triggered after all channels have been looped through. It currently serves no purpose, though it may in the future.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


On client channels loop

This condition is triggered for each client in a channel. The client and channel will be selected for you.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


On client channels loop finished

This condition is triggered when the loop of all the clients in a channel is finished.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


[With loop name] On all channels loop

This condition is triggered for each channel in a channel loop of all channels on the server. The channel will be selected for you. It takes one parameter, which is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


[With loop name] On all channels loop finished

This condition will be triggered after all channels have been looped through. It currently serves no purpose, though it may in the future. It takes one parameter, which is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


[With loop name] On client channels loop

This condition is never triggered because there is no corresponding action to trigger it.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


[With loop name] On client channels loop finished

This condition is never triggered because there is no corresponding action to trigger it.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Channel is hidden from the channel list

This condition is true if the currently selected channel is marked as hidden from the channel list. This property can only be set by the client that creates the channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Channel is set to close automatically

This condition is true if the currently selected channel is marked to close when the channel master leaves. This property can only be set by the client that creates the channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Client is the channel master

This condition is true if the currently selected client is the channel master of the currently selected channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


On name set request

This condition is triggered when a client requests to set or change their name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


On all clients loop

This condition is triggered for each client on the server. The client is selected for you, but the selected channel is not affected as clients can be in more than one channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


On all clients loop finished

This condition is triggered when the loop of all clients has completed.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


On channel clients loop

Despite the name being an obvious copy and paste from the Channel submenu, this condition is triggered for each channel a client is in. Both the client and channel are selected for you.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


On channel clients loop finished

Despite the name being an obvious copy and paste from the Channel submenu, this condition is triggered when the loop of all channels a client is in has completed.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


[With loop name] On all clients loop

This condition is triggered for each client on the server. The client is selected for you, but the selected channel is not affected as clients can be in more than one channel. Its only parameter is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


[With loop name] On all clients loop finished

This condition is triggered when the loop of all clients has completed. Its only parameter is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


[With loop name] On channel clients loop

Despite the name being an obvious copy and paste from the Channel submenu, this condition is triggered for each channel a client is in. Both the client and channel are selected for you. Its only parameter is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


[With loop name] On channel clients loop finished

Despite the name being an obvious copy and paste from the Channel submenu, this condition is triggered when the loop of all channels a client is in has completed. Its only parameter is the name of the loop.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


On text message to server

This condition is triggered when a client has sent a text message to the server. The client is selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


On number message to server

This condition is triggered when a client has sent a number message to the server. The client is selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


On binary message to server

This condition is triggered when a client has sent a binary message to the server. The client is selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


On any message to server

This condition is triggered when a client has sent a message to the server. The client is selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


On text message to channel

This condition is triggered when a client has sent a text message to a channel. The client and channel are selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


On number message to channel

This condition is triggered when a client has sent a number message to a channel. The client and channel are selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


On binary message to channel

This condition is triggered when a client has sent a binary message to a channel. The client and channel are selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


On any message to channel

This condition is triggered when a client has sent a message to a channel. The client and channel are selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


On text message to peer

This condition is triggered when one client has sent a text message to another client. The channel is selected for you, but there is an obvious conceptual error as to which client is selected. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


On number message to peer

This condition is triggered when one client has sent a number message to another client. The channel is selected for you, but there is an obvious conceptual error as to which client is selected. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


On binary message to peer

This condition is triggered when one client has sent a binary message to another client. The channel is selected for you, but there is an obvious conceptual error as to which client is selected. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


On any message to peer

This condition is triggered when one client has sent a message to another client. The channel is selected for you, but there is an obvious conceptual error as to which client is selected. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


On text message to server

This condition is triggered when a client has blasted a text message to the server. The client is selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


On number message to server

This condition is triggered when a client has blasted a number message to the server. The client is selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


On binary message to server

This condition is triggered when a client has blasted a binary message to the server. The client is selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


On any message to server

This condition is triggered when a client has blasted a message to the server. The client is selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


On text message to channel

This condition is triggered when a client has blasted a text message to a channel. The client and channel are selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


On number message to channel

This condition is triggered when a client has blasted a number message to a channel. The client and channel are selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


On binary message to channel

This condition is triggered when a client has blasted a binary message to a channel. The client and channel are selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


On any message to channel

This condition is triggered when a client has blasted a message to a channel. The client and channel are selected for you. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


On text message to peer

This condition is triggered when one client has blasted a text message to another client. The channel is selected for you, but there is an obvious conceptual error as to which client is selected. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


On number message to peer

This condition is triggered when one client has blasted a number message to another client. The channel is selected for you, but there is an obvious conceptual error as to which client is selected. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


On binary message to peer

This condition is triggered when one client has blasted a binary message to another client. The channel is selected for you, but there is an obvious conceptual error as to which client is selected. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


On any message to peer

This condition is triggered when one client has blasted a message to another client. The channel is selected for you, but there is an obvious conceptual error as to which client is selected. It takes one parameter, which is the subchannel to filter this condition for.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Error string (for on error)

S This expression returns the error string from the most recently triggered error condition.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Lacewing version string

S This expression returns the version string for the version of Lacewing that this server extension wraps.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Port

N This expression returns the port that the server is hosting on. This is not for the flash policy server, which always hosts on port 843.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Binary to send size

N This expression returns the size in bytes of the binary to send.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Binary to send address

N This expression returns the address of the binary to send. This can be used in conjunction with extensions like Binary Quickload and the Memory Object for quickly filling the binary to send with data.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Requested name (for name set/change request)

S This expression returns the requested name for a client (as the client's name has not been set at the point of triggering the On name set request condition).

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Requested channel name (for channel join request)

S This expression returns the requested name of the channel that a client wants to join. Even if the channel exists, the channel is not selected because the client is not actually in the channel at the point of triggering the On join request condition.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Name

S This expression returns the name of the currently selected channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Client count

N This expression returns the number of clients in the currently selected channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Get local channel data

S This expression retrieves the value string associated with the given key string for the currently selected channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


Number of channels on the server

N This expression returns the number of channels currently on the server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Name

S This expression returns the name of the currently selected client.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


ID

N This expression returns the ID of the currently selected client.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


IP address

S This expression returns the IP address of the currently selected client as a string.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Connection time

? This expression has been removed from Lacewing, but the menu name has not. Bug Jamie about it.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Channel count

N This expression returns the number of channels the currently selected client is in.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Get local client data

S This expression retrieves the value string associated with the given key string for the currently selected channel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Get client protocol implementation

? This expression has been removed from Lacewing, but the menu name has not. Bug Jamie about it.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


Get text

S This expression returns the received message as text.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Get number

N This expression returns the received message as a number.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Get binary size

N This expression returns the size of the received binary data.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Get binary memory address

N This expression returns the memory address of the received binary data.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


ASCII character

S This expression returns a string containing the single character represented by the indicated byte. It takes one parameter, which is the location of the byte in the binary message, with a 0-based index.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Unsigned

N This expression returns the unsigned representation of the single byte at the specified location in the binary message. It takes one parameter, which is the location of the byte in the binary message, with a 0-based index. The value returned will be in the range 0 to 255.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Signed

N This expression returns the signed representation of the single byte at the specified location in the binary message. It takes one parameter, which is the location of the byte in the binary message, with a 0-based index. The value returned will be in the range -128 to 127.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Signed

N This expression returns the signed representation of the two-byte short at the specified location in the binary message. It takes one parameter, which is the location of the short in the binary message, with a 0-based index. The value returned will be in the range -32768 to 32767.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Unsigned

N This expression returns the unsigned representation of the four-byte integer at the specified location in the binary message. It takes one parameter, which is the location of the integer in the binary message, with a 0-based index. The value returned would be in the range 0 to 4294967295, but MMF2 will truncate this value to be within the range -2147483648 to 2147483647, making this expression the same as getting the Signed integer.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Signed

N This expression returns the signed representation of the four-byte integer at the specified location in the binary message. It takes one parameter, which is the location of the integer in the binary message, with a 0-based index. The value returned will be in the range -2147483648 to 2147483647.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Float

N This expression returns the floating-point representation of the four-byte float at the specified location in the binary message. It takes one parameter, which is the location of the float in the binary message, with a 0-based index. The value returned will be in the range -3.4e38 to 3.4e38.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


With size

S This expression returns the string at the specified location in the binary message. It takes two parameters, the first being the location of the string in the binary message, with a 0-based index, and the second being the size in bytes/characters of the string to read.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


Null terminated

S This expression returns the string at the specified location in the binary message. It takes one parameter, which is the location of the string in the binary message, with a 0-based index. The string will be read until a null terminator character is found in the binary message (byte value 0).

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free HTML Help documentation generator


ASCII character

S This expression returns a string containing the single character represented by the byte at the cursor.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Unsigned

N This expression returns the unsigned representation of the single byte at the cursor. The value returned will be in the range 0 to 255.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Signed

N This expression returns the signed representation of the single byte at the cursor. The value returned will be in the range -128 to 127.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Unsigned

N This expression returns the unsigned representation of the two-byte short at the cursor. The value returned will be in the range 0 to 65535.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Signed

N This expression returns the signed representation of the two-byte short at the cursor. The value returned will be in the range -32768 to 32767.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Unsigned

N This expression returns the unsigned representation of the four-byte integer at the cursor. The value returned would be in the range 0 to 4294967295, but MMF2 will truncate this value to be within the range -2147483648 to 2147483647, making this expression the same as getting the Signed integer.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Float

N This expression returns the floating-point representation of the four-byte float at the cursor. The value returned will be in the range -3.4e38 to 3.4e38.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free PDF documentation generator


With size

S This expression returns the string at the cursor. It takes one parameter, which is the size in bytes/characters of the string to read.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Null terminated

S This expression returns the string at the cursor. The string will be read until a null terminator character is found in the binary message (byte value 0).

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


Get subchannel

N This expression returns the subchannel that the message was received on.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


Version

This property displays the version string of the Lacewing library that this server extension wraps.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Automatically clear binary

If this property is ticked, the binary to send will be cleared after sending/blasting the binary message

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Global

If ticked, this server object will be global across frames and sub-apps to other server objects that have the same global identifier.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Global identifier

This property is the global identifier to be used to determine whether two server objects share the same state or not. It can be blank or equivalent to Villy.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Lacewing Webserver

The Lacewing Webserver is an object which allows you to host a completely customizable Lacewing Webserver, hosing either an HTTP server, and HTTPS server, or both, and handling GET, POST, and HEAD requests from HTTP clients (such as web browsers). You must generate response messages yourself in the same event as the On [..] request conditions, though it may be broken up into several On [..] request events. The header is generated for you, with you being able to change some things (such as MIME type and/or Location: header items). You as the programmer must design it to behave in any way you see fit, be it actually for hosting a website or for acting as a miniature remote control panel.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Host

Attempts to begin hosting a normal HTTP server on the given port.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Stop hosting

Attempts to stop hosting the HTTP server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


Host

Attempts to host an HTTPS server on the given port.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Stop hosting

Attempts to stop hosting the HTTPS server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Load certificate from system

Loads a certificate for the HTTPS server from the given store, common name, and location.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Set MIME type

Sets the MIME type in the header from the given string. This is useful if you want to force a different MIME type than Lacewing would guess.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Set MIME type (with charset)

Sets the MIME type from the given string and also the charset from the given string in the header.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Set cookie

Sets a cookie by name to the specified string value. Useful for storing long-term session data, but not as tasty.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


Disable response caching

Prevents web browsers from caching the response for faster page loading. This is useful if you want the page to be downloaded from the server every time.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Set as unmodified

Tells web browsers that the page or file being requested has not changed from before.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Set last modified

Sets the Last Modified time from the given Unix time value.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


String

Adds the given string parameter to the end of the response.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


File

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


Guess MIME type

Adds the given file to the end of the response, changing the MIME type to Lacewing's best guess at what the file is.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Leave the MIME type alone

Adds the given file to the end of the response while not affecting the MIME type in any way.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Set big endian

Sets the binary mode to Big Endian.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Set little endian (default)

Sets the binary mode to Little Endian.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Byte

Adds the given one byte byte to the end of the response.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Short

Adds the given two byte short to the end of the response.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Integer

Adds the given four byte integer to the end of the response.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


From memory address

Adds data from the given memory address for the given number of bytes.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Redirect to another URL

Adjusts the header so that the browser will go to the given URL after the request is finished. You can still add information to the request, but most browsers will not show any of it as they will have already gone to the new URL.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


On error

This condition is triggered upon an error occurring, such as not being able to host the server because there is already another server hosting on the same port.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


HTTP server is hosting

This condition is true if the HTTP server is hosting at all.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


HTTPS server is hosting

This condition is true if the HTTPS server is hosting at all.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


HTTPS certificate is loaded

This condition is true if an HTTPS certificate is loaded.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


On disconnect

This condition is triggered when a client disconnects from the web server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Connection is HTTPS

This condition is true if the request currently being processed is through the HTTPS server rather than the regular HTTP server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


On GET request

This condition is triggered when a connected client sends a GET request.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


On POST request

This condition is triggered when a connected client sends a POST request.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


On HEAD request

This condition is triggered when a connected client sends a HEAD request (where they only want the header).

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Error string (for on error)

S This expression returns the error string from the last triggered error.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Lacewing version string

S This expression returns the version string of the Lacewing library this Webserver object wraps.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Get connection IP address

S This expression returns the IP address of the client whose request is currently being processed.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Get local connection data

S This expression returns the data associated with the given key for the current whose request is currently being processed. It is useless, however, because there is no action to set the local connection data in the first place.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Bytes sent

N This expression returns the number of bytes that have been sent throughout the lifetime of the server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Bytes received

N This expression returns the number of bytes that have been received throughout the lifetime of the server.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Get URL

S This expression returns the requested URL, without the hostname or protocol.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Get header

S This expression returns the header item with the given name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Get cookie

S This expression returns the string value of a cookie with the given name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Get last modified time

N This expression returns the last modified time in Unix units for the given name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easy CHM and documentation editor


Get GET item

S This expression returns the GET item with the given name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free CHM Help documentation generator


Get POST item

S This expression returns the POST item with the given name.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Get hostname

S This expression returns the hostname for which the client is requesting data. This is useful if the same server is used to host multiple sites with different hostnames.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Guess MIME type for filename

S This expression would return the MIME type for the given filename, but it can't actually be given a filename due to a programming error. It accepts a nameless number parameter rather than the expected filename string parameter, making it useless.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Version

This property displays the version string of the Lacewing library that this Webserver object wraps.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Global

If ticked, this allows Webserver objects with the same global identifier to share state across frames and sub applications.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents


Global identifier

This is the global identifier used to determine which Webserver objects share state with each other.

LB's Lacewing Help for Lacewing Build 20, revision 2

Created with the Freeware Edition of HelpNDoc: Easily create Help documents